1. Home
  2. Initial Setup
  3. Privileges and Settings – Settings Maintenance Sub window

Privileges and Settings – Settings Maintenance Sub window

Contents

OVERVIEW

This sub window is used in the User Settings Maintenance window and in the System, Group and User panes in the Privileges and Settings window (File > System > Privileges and Settings)

Settings are an array of values and options that can be applied at a System, Group and User level. Some are additive, such as Custom Reports, Custom Features and Options so that a user will gain the options he inherits from the System, any Groups he belongs to and his own User options. Others such as ScratchPads, Email and General overwrite if they exist in a System, Group and User sequence.

It is best to fully populate the System settings which will apply to all users and then apply Group and User settings judicially only as needed.

Settings are stored separately in the System data record, Group records and User records. Any changes need to be saved before switching to another context. Revert and Save buttons are available on all panes.

This article is part of the Vision Setup Guide. Click Here to return to the Setup Guide.

File Path

File > Preferences > User Settings

This file path takes you to the User Settings Maintenance window. This window has 7 tabs.

General Tab

Graphical user interface, text, application

Description automatically generated

This tab has general group, user and system settings.

Internet Identity field

Email Address

Enter the email address that will be used for documents (User overrides group overrides system)

WWW (URL)

World Wide Web address (URL) that will be used for documents (User overrides group overrides system)

Program Operation field

Max open tasks

This is the maximum number of open tasks (functional areas of the program) before old ones are automatically closed. (if non-zero, user overrides groups overrides system).

Max open windows

The maximum number of open windows before old ones are automatically closed. (if non-zero, user overrides groups overrides system).

Max messages logged

The number of OK and Yes/No messages held in log before old ones are automatically cleared. (if non-zero, user overrides groups overrides system).

Working message delay

The delay in sixtieths of a second before a working message is opened (reduces message flashing). -1 clears group or system setting.

Working message icon speed

The speed in sixtieths of a second between state changes of the working message icon. -1 clears group or system setting.

List search timeout (1/60 sec)

The speed in sixtieths of a second until a list search times out.

Old (pre V4) List Searching

Ticking this box will remove the time out function.

If checked, menus will have icons. This will only apply on next startup on this terminal of this programme and is not stored in the settings. This setting is for Windows only.

Taskbar – None

No taskbar will be shown

Taskbar – Top

Taskbar will be shown at the top of the display window.

Taskbar – Bottom

Taskbar will be shown at the bottom of the display window.

Show System Focus (Macintosh only)

If checked, a system highlight focus rectangle will be applied to the current active object. This applies to most standard object types that respond to keyboard activity. This is for Macintosh only.

Report errors in – Notation

If checked any runtime program notation errors will be reported. This is used for potentially identifying the causes of problems. It is generally not recommended that this is switched on unless you are asked to by technical support staff.

Report errors in – Calculations

If checked any runtime program calculation errors (such as divide by zero) will be reported. This is used for potentially identifying the cause of problems. It is not generally recommended that this is switched on unless you are asked to by technical support staff.

Disable headed list ellipsis

Normally if headed lists have columns set too narrow to show all the data, an indication is given with a … If this control is checked this display feature is disabled.

Headed list with sort arrow rather than bold/italic

The sort column of a headed list can be indicated by an arrow or by the column heading text being set bold and italic when the order is reversed. This controls which of these options is used.

Check for language improvements on start up

Applies to non-English language editions only. If checked the user will, if connected to the Internet, automatically perform a language upgrade check and upload any language improvements for use by network users.

NOTE: If you have non-English language editions operating on your site, at least one language edition user for each language must have this setting checked for the site to receive language updated automatically.

Custom Reports tab

In this tab you can set the custom reports that are used in place of standard reports or supplement them.

These settings are applied in a System then Group membership then user order.

You can find the Report Class name at File > Advanced > Change Management System. Clicking on the List Lib. button will bring up a list of report names. Any custom reports you have requested are at the top of the list.

All report selection dialogues in the system can have custom reports added to them. These are listed by clicking on the Report Types button. Other reports, not deriving from selection dialogues can also be substituted or supplemented with custom reports by entering the standard report class name in the Report Type.

Grid of Custom Reports

In this grid you will find a list of all custom reports that are available to the group, user or system.

Type

Custom report type which is used to apply where the report is used. Typically, this is a two or more letter code that is case-insensitive.

To get a list of all report types supported, click the Report Types button at the bottom of the window.

Sub-type

Custom report sub-type which is used to apply where the report is used. Normally 0, this can control alternative data collection methods. For a list of all sub-types supported, click the Report Types button at the bottom of the window.

In the Alert Message window, letters after = are the report ‘type’. Numbers below the type (if any) are the ‘sub-type’

Report class

This is the programme name of the report eg: rWorkOrderB – this example is a Work Order which includes barcodes for work operations, this report comes as standard with Caliach Vision but is not setup ‘out of the box’, it’s type is WO and there is no sub-type

Graphical user interface, text, application

Description automatically generated

If you enter an incorrect report class, you will receive this error.

NOTE: The report class is case sensitive.

Graphical user interface, text, application

Description automatically generated

Title

This is the title that the user sees when selecting the report. You can change the title name and selecting save will over-ride the pre-programmed title.

Eg. In this example we have renamed the Work Order with Barcodes to Work Order (Barcodes).

Graphical user interface, application, Word

Description automatically generated

Dynamic query name

This is an optional search class that can be used in conjunction with the custom report.

Active

If unchecked the system will ignore the entry. This is useful where you want to disable a user’s use of a group report.

Report Types button

When selected, a list of applicable report types will show.

Custom Features Tab

Graphical user interface, application, Word

Description automatically generated

Custom features that are to be available. These Settings are applied in a System then Group membership then User order.

Grid of Custom Features

This displays a list of all custom features that are available to the group, user or system. To remove an entry, clear the rows Window class entry and the row will be removed when saved.

To create a new entry, tab past the end of the last column of the last line on the grid. A new line will appear underneath.

Section

This will be the name of the subcategories within the user menu structure.

Table

Description automatically generated

In our example above we have added several menu options so our user menu will look like the image below.

The section name becomes the group heading.

Graphical user interface, application

Description automatically generated

Window Class

The window class name that will open when the menu is operated.

Title

The title that will be shown on the group menu.

Active

If this is ticked it indicates the feature is active for the group or user.

Scratchpads tab

Here you can set the display columns of the scratchpads

Scratchpad dropdown list

Here you choose which scratchpad you wish to maintain.

Field list

This is a list of the available data fields for the selected scratchpad. To add a field, drag lines from this list into the column list.

Scratchpad column list

The list of columns that will be presented on the scratchpad. To reorder, drag and drop to required place. You can edit the heading in the list by double clicking on the name.

Maximum lines

The maximum number of lines that are permitted in the scratchpad.

Auto add

With this box checked, lines will be automatically added to the scratchpad as the program encounters records.

Calculated Button

Click this button to amend or add a calculated field.

Email tab

Graphical user interface, text, application, email

Description automatically generated

In this tab you will set the email setting that a user will have when sending emails from the program.

All email settings apply as a set to a user if there is any Email Address text entered and will apply with the following priority: User, Group membership, System. So by the correct use of settings you can have an individual (user) eg. ssmith@mycompany.com, departmental (group), sales@mycompany.com and company (system), sales@mycompany.com. Each can point to a different server.

User information field

User details needed when printing to the email report destination.

Name

Your full name to be used when printing to the email report destination.

Email address

Users email address.

Reply address

This is the email address that will be shown as the reply address.

Always cc to

Optional email address(s) to which a copy of all emails will be sent.

Signature after email

The signature text that will end any email message sent.

Server information field

STMP server

The IP name or address of the Simple Mail Transfer Protocol server that emails will be sent to. By default port 25 is used but that can be overridden using a : (colon) delemiter, as in www.mydomain.com:999.

Authentication name

Account name used for authentication with the server (supports LOGIN and PLAIN methods only). If there is no name entered, no authentication is attempted.

Authentication password

Authentication password which is sent along with the name so that the email server can authenticate the sender (as a spam prevention tool).

Secure

These options control the use of OpenSSL (which must be installed on the client computer) in communicating with the mail server.

Selecting No turns off OpenSSL for communications to the email server.

Selecting Yes, means OpenSSL secures the connection using OpenSSL to the email server.

Selecting the STARTTLS option means the communication with the server will be by STARTTLS protocols.

Ticking the verify box will allow the system to verify the secure connection.

Attachments grid

When reports are sent by email, the report is rendered into a public format and attached to a simple text email. You can control the attached file format here. Setting applies to users only.

Acrobat PDF

If selected, attachments will be in Acrobat PDF format.

HMTL

If selected, attachments will be in HMTL format.

Defaults tab

Graphical user interface, text, application, email

Description automatically generated

Here we set the default settings that can apply

Default to Sales Order rather than Quotation

If ticked, when a new quotation of sales order is created, it will initially be a sales order.

Default to Purchase Order rather than a Request for Quotation

If ticked, when a new RFQ or purchase order is created it will initially be a purchase order.

Default to Work Order Backflushed rather than Normal

If ticked, when a new Work Order is created it will initially be marked for Backflushing.

Default to Job rather than Estimate

If checked, when a new Job or Estimate is created it will initially be marked as a Job.

Do not Clear Window when Preforming a Find

Normally, when performing a Find operation, the window is cleared of data. If this box is ticked, this will leave any data present in the window.

Encoding for import when no BOM

When importing from text data, when the file has no Unicode Byte Order Marker (BOM), the selected encoding will be used. Default is kUniTypeNativeCharacters. Click on the dropdown menu for more options.

Encoding for Exporting

When exporting to text data or printing to port or text the selected encoding will be used. Default is kUniTypeUTF8. Click on the dropdown menu for more options.

Set Byte Order Mark at the start of exported text

If ticked, and the Encoding for Exporting is set to a Unicode encoding, a Unicode BOM is output at the start of the output file.

Options tab

Graphical user interface, text, application, Word

Description automatically generated

Extra options that may apply can be added here.

Option field

Here is where options that will be added to the option list go. All take the form of optXXXX=Value ;;Comment. The optional comment is a reminder and must be prefixed with a space and two semicolons.

Show Options List button

Clicking this button will bring up the below window of available options. You can drag an option from here into the option field and it will install from there.

Program Options Listing window

Graphical user interface, table

Description automatically generated

Selecting this button will bring up a report showing all the current options for the System, Groups and Users settings and any Server, Terminal and License files.

Text

Description automatically generated

BUTTONS AND FIELDS

Revert

Selecting this button will revert data to the last saved point.

Save

Selecting this button will save changes you have made.

This article is part of the Vision Setup Guide. Click Here to return to the Setup Guide.

Compiled in Program Version 6.00.

Class wSettings (User Settings Maintenance) FP: File > Preferences > User Settings

Updated on September 22, 2021

Related Articles